"The file format and extension of <FILENAME> don't match." when opening a spreadsheet from Hosted

ISSUE

When opening a spreadsheet file downloaded from Reckon Accounts Hosted, it returns the following error:

Microsoft Excel
The file format and extension of ’<FILENAME>.xls’ don't match. The file could be corrupted or unsafe. Unless you trust its source, don't open it. Do you want to open it anyway




CAUSE

With the recent changes in the Office Integration for Reckon Accounts Hosted, all the workbook files will now be of an XLSX file type. Generally, the above error is due to a conflict with the file type specified on the file name and the actual type of file.

The issue may arise when selecting to export a report to a New workbook but proceeding to select an existing spreadsheet file with a file type of XLS to overwrite it. This retains the filename with the current file type, but the data within is of an XLSX.

Clicking Yes will proceed in opening the spreadsheet.



WORKAROUND

  1. Do not overwrite an existing XLS file when exporting with New workbook option but enter a unique name
  2. Select the option to use an Existing workbook instead
  3. Open the file with the error and save the file as an XLSX



How did we do?

Time duration does not calculate the Totals in an exported Time by Job report from Reckon Accounts Hosted

Office Integration changes in Reckon Accounts Hosted

Related Articles

Powered by HelpDocs (opens in a new tab)

Powered by HelpDocs (opens in a new tab)