Why do I get an error iKernel.exe The system cannot read from the specified device when installing Reckon Accounts
Legacy KB ID: 1191
Question
This problem comes when going in and clicking on setup.exe or trying to install. The ikernel is an installation engine that enables setup.exe to be run.
Answer
Re-check that the installation is not running twice.
What you need to do is either press > CTRl+ALT+DEL and > END TASK all the setup.exe (not responding) and close them.
Alternatively you may need to restart the computer and try to install it, and it should work this time.
RESOLUTION
To resolve this issue, delete the Install Shield folder using the following steps.
1. Start > My Computer from the desktop
2. Browse to C:\Program Files\Common Files\Install Shield by clicking on > C:\ drive > Program Files > Common Files > Install Shield
3. Right-click on the folder > Install Shield, and then click > Delete on the shortcut menu
4. When the confirmation message appears, click > Yes
5. Restart your computer
6. Install from the Hard Drive (HDD)
If the Install Shield folder doesn't exist use the following alternate solution.
1. Start > My Computer from the desktop
2. Browse to C:\Windows\Temp by clicking on > C:\ drive > Windows > Temp
3. Delete the entire contents of the temp folder, if a file can't be delete leave it and delete the rest.(It would be best to send the files to the recycle bin to avoid any problems later)
4. Restart your computer
5. Install from the HDD
SYMPTOMS
When you attempt to install a program, you may receive an error message similar to one of the following:
- Ikernel caused an Invalid Page Fault in module unknown.
- Setup failed to launch installation engine, no such interface supported.
- Error extracting support files: Class not registered.
CAUSE
This issue can occur when there are damaged files in the C:\Program Files\Common Files\Install Shield folder. The Install Shield folder is similar to C:\WINDOWS\TEMP folder. After you install the program, the contents of this folder are no longer needed or used.
Need more help?
Ask the Reckon Community at: https://community.reckon.com/categories/reckonaccounts
Or
Log a Support Ticket: https://www.reckon.com/au/support/